понедельник, 1 марта 2010 г.

Установка и запуск браузера Safari 4 в Ubuntu Linux

Как вы наверное знаете, Safari является браузером по умолчанию в Mac OS X и iPhone OS. Вышло уже несколько релизов и для Windows, но версии для Linux нет. Ниже приведено пошаговое руководство по установку и запуску Safari 4 на Ubuntu Linux.


Шаг 1. Установите Wine. Самый простой способ - установить его из репозитория, используя Центр приложений Ubuntu либо менеджер пакетов Synaptic.


Шаг 2. Скачайте winetricks с помощью следующей команды:


wget http://www.kegel.com/wine/winetricks


Шаг 3.  Установите winetricks, шрифты и flash:


sh winetricks corefonts flash



Шаг 4.  Скачайте Safari для Windows отсюда.


Шаг 5. Перейдите в папку, в которую вы сохранили инсталлятор Safari, и откройте его в Wine с помощью команды: 


wine SafariSetup.exe


Шаг 6. Установите Safari, убедившись, что опции "Install Bonjour for Windows" и "Automatically update Safari..." отключены.




Шаг 7. Запустите Safari из меню Приложения->Wine->Программы->Safari->Safari.


Несколько замечаний:
- при первом запуске Safari сначала аварийно завершится из-за анимационной заставки, но затем будет работать;
- если Flash не будет работать, скачайте и установите его вручную;
- открытие новой вкладки может приводить к падению программы. Чтобы предотвратить его, откройте диалог настроки браузера в категории "General", найдите опцию "New tabs open with:" и установите ее значение "Empty Page".


Перевод. Оригинал на http://www.junauza.com

9 комментариев:

  1. у меня вот что пишет
    wine: cannot find L"C:\\windows\\system32\\SafariSetup.exe"

    ОтветитьУдалить
  2. нафига парится с сафари если много есть браузеров на технологии вебкит тот же хром!

    ОтветитьУдалить
  3. Пля, какой умный! Затем, что иногда для техподдержки нужно, чтобы попробовать, если у клиента на Маке под сафари сайт криво отображается

    ОтветитьУдалить
  4. Линуксовый браузер на том же движке — Konqueror. С некоторыми оговорками можно даже при тестировании вёрстки взаимозаменять Safari и Konqueror.

    А safari под WINE - это для мазохистов

    ОтветитьУдалить
    Ответы
    1. "А safari под WINE - это для мазохистов"
      Может для программистов? Или, вернее, для веб-программистов. А может для веб-разработчиков? или верстальщиков, а? Не пугайте людей столь поспешными комментариями.

      Удалить
  5. Все установил по приведенным инструкциям, но браузер не работает - не загружаются страницы. В чем дело?

    ОтветитьУдалить
  6. Тоже браузер не работает, не открывается ни одна страница...

    ОтветитьУдалить
  7. нужно всё!
    Вот мне для работы нужен ИЕ9 или я уже узнал что можно сафари...
    есть конечно винда, но охота полностью пересесть на линукс, потому что если кто нить ставит игрушку на винду, то для моей работы нужно полностью чистить реестр, или переустанавливать винду, последнее получается быстрее...
    так что лучше запустить под вайном или ИЕ9 (пока не получилось), или сафари.
    Так что это кому то всё таки нужно, кому то для хобби, кому то для работы

    ОтветитьУдалить