рекомендации

суббота, 21 октября 2017 г.

Установка пакета Quantstrat в последних версиях R

Пакет Quantstrat используется трейдерами для тестирования торговых стратегий на R. Однако в последних версиях R при попытке его установки мы видим сообщение об ошибке:

Warning in install.packages :
  package ‘quantstrat’ is not available (for R version 3.4.1)

Поскольку разработчики пакета переместили его из R-Forge на github, теперь необходимо собирать его из исходного кода, размещенного на github. Сначала необходимо установить инструменты разработчика:

install.packages("devtools")
require(devtools)

Затем устанавливаем пакет blotter, который является необходимой зависимостью (его мы также собираем из исходного кода), и, наконец, quantstrat:

install_github("braverock/blotter")
install_github("braverock/quantstrat")

Комментариев нет:

Отправить комментарий